IsValidType Method


Checks if the type is a valid alignment station label type.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2021.1

Syntax

C#
public static bool IsValidType(
	Element type
)
Visual Basic
Public Shared Function IsValidType ( _
	type As Element _
) As Boolean
Visual C++
public:
static bool IsValidType(
	Element^ type
)

Parameters

type
Type: Autodesk.Revit.DBElement
The element type to validate.

Remarks

Can be used for finding or types to be set to TypeId when creating alignment label sets with Create(Alignment, View, AlignmentStationLabelOptions); or types to be set to TypeId when creating alignment labels with CreateSet(Alignment, View, AlignmentStationLabelSetOptions).

See Also