UnhideElements Method


Sets the elements to be shown in the given view if they are currently hidden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void UnhideElements(
	ICollection<ElementId> elementIdSet
)
Visual Basic
Public Sub UnhideElements ( _
	elementIdSet As ICollection(Of ElementId) _
)
Visual C++
public:
void UnhideElements(
	ICollection<ElementId^>^ elementIdSet
)

Parameters

elementIdSet
Type: System.Collections.GenericICollectionElementId
A set of ElementIds to be unhidden.

Remarks

This change is permanent until the elements are hidden again. All elements in the set must be currently hidden. An application can check this with IsHidden(View).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptionThrown when argument is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentExceptionThrown when the set of elements to be unhidden is empty or one of the elements can not be unhidden.
Autodesk.Revit.ExceptionsInvalidOperationExceptionThrown when document regeneration failed.

See Also