UnhideElements Method


View Unhide Elements Method

Sets the elements to be shown in the given view if they are currently hidden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void UnhideElements(
	ICollection<ElementId> elementIdSet
)

Parameters

elementIdSet ICollection ElementId
A set of ElementIds to be unhidden.
Exceptions
Exception Condition
ArgumentNullException Thrown when argument is .
ArgumentException Thrown when the set of elements to be unhidden is empty or one of the elements can not be unhidden.
InvalidOperationException Thrown when document regeneration failed.
Remarks
This change is permanent until the elements are hidden again. All elements in the set must be currently hidden. An application can check this with IsHidden(View) .
See Also