Regeneration |
The custom regeneration attribute to control the regeneration behavior of the external command or external application.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RegenerationAttribute type exposes the following members.

Name | Description | |
---|---|---|
![]() | RegenerationAttribute | Constructs a new RegenerationAttribute. |

Name | Description | |
---|---|---|
![]() | Option | Regeneration option. |
![]() | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute . (Inherited from Attribute ) |

Name | Description | |
---|---|---|
![]() | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute ) |
![]() | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute ) |
![]() | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |