RegenerationAttribute Class


Regeneration Attribute Class

The custom regeneration attribute to control the regeneration behavior of the external command or external application.
Inheritance Hierarchy
System Object
System Attribute
Autodesk.Revit.Attributes RegenerationAttribute

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RegenerationAttribute : Attribute

The RegenerationAttribute type exposes the following members.

Constructors
Name Description
Public method RegenerationAttribute Constructs a new RegenerationAttribute.
Top
Properties
Name Description
Public property Option Regeneration option.
Top
Methods
Name Description
Top
See Also