RebarBendData Class


Rebar Bend Data Class

The values in this class provide a summary of information taken from the RebarBarType, RebarHookType, and RebarStyle.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarBendData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarBendData : IDisposable

The RebarBendData type exposes the following members.

Constructors
Name Description
Public method RebarBendData Constructs a new RebarBendData with default settings.
Public method RebarBendData(RebarBarType, RebarHookType, RebarHookType, RebarStyle, RebarHookOrientation, RebarHookOrientation) Constructs a new RebarBendData using the bar type, hook types, style and orientation values.
Top
Properties
Name Description
Public property BarModelDiameter Defines the model diameter of the bar.
Public property BarNominalDiameter Defines the nominal diameter of the bar.
Public property BendRadius The radius of all fillets, except hook fillets, in the Rebar shape.
Public property HookAngle0 The angle of the hook at the start.
Public property HookAngle1 The angle of the hook at the end.
Public property HookBendRadius The radius of the hook fillets in the Rebar shape.
Public property HookLength0 The extension length of the hook at the start.
Public property HookLength1 The extension length of the hook at the end.
Public property HookOrient0 The orientation of the hook at the start.
Public property HookOrient1 The orientation of the hook at the end.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RebarBendData
Top
Remarks
The purpose of collecting the values in this class is to allow you to create and analyze an accurate representation of a RebarShape, without creating a Rebar instance, and without referring to RebarBarType, RebarHookType, and RebarStyle. If you do have a Rebar instance, its GetBendData() method will produce a RebarBendData object.
See Also