RebarBendData Class


Rebar Bend Data Class

The values in this class provide a summary of information taken from the RebarBarType, RebarHookType, and RebarStyle.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarBendData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class RebarBendData : IDisposable

The RebarBendData type exposes the following members.

Constructors
Name Description
Public method RebarBendData Constructs a new RebarBendData with default settings.
Public method RebarBendData(RebarBarType, RebarStyle, BarTerminationsData) Constructs a new RebarBendData using the bar type, style and termination's values.
Public method RebarBendData(RebarBarType, RebarHookType, RebarHookType, RebarStyle, RebarHookOrientation, RebarHookOrientation) Obsolete.
Constructs a new RebarBendData using the bar type, hook types, style and orientation values.
Top
Properties
Name Description
Public property BarModelDiameter Defines the model diameter of the bar. The default value is 0.0. When this is changed, the CrankStraightLength0, CrankStraightLength1, CrankAnledLength0, CrankAnledLength1 will be recomputed.
Public property BarNominalDiameter Defines the nominal diameter of the bar. The default value is 0.0.
Public property BendRadius The radius of all fillets, except hook fillets, in the Rebar shape. The default value is 0.0.
Public property CrankAngledLength0

Identifies the crank angled length at the start.

The default value is 0. A positive value means that there is a valid crank. If the value is 0 it means that there is no crank. If the value is negative it means that there is a crank with incorrect values.

Public property CrankAngledLength1

Identifies the crank angled length at the end.

The default value is 0. A positive value means that there is a valid crank. If the value is 0 it means that there is no crank. If the value is negative it means that there is a crank with incorrect values.

Public property CrankLength0

Identifies the crank length at the start.

The default value is 0. A positive value means that there is a valid crank. If the value is 0 it means that there is no crank. If the value is negative it means that there is a crank with incorrect values.

Public property CrankLength1

Identifies the crank length at the end.

The default value is 0. A positive value means that there is a valid crank. If the value is 0 it means that there is no crank. If the value is negative it means that there is a crank with incorrect values.

Public property CrankOffsetLength0

Identifies the crank offset length at the start.

The default value is 0. A positive value means that there is a valid crank. If the value is 0 it means that there is no crank. If the value is negative it means that there is a crank with incorrect values.

Public property CrankOffsetLength1

Identifies the crank offset length at the end.

The default value is 0. A positive value means that there is a valid crank. If the value is 0 it means that there is no crank. If the value is negative it means that there is a crank with incorrect values.

Public property CrankRatio0

Identifies the crank ratio at the start. The 1:crankRatio that defines the crank slope.

The default value is 0. A positive value means that there is a valid crank. If the value is 0 it means that there is no crank. If the value is negative it means that there is a crank with incorrect values.

Public property CrankRatio1

Identifies the crank ratio at the end. The 1:crankRatio that defines the crank slope.

The default value is 0. A positive value means that there is a valid crank. If the value is 0 it means that there is no crank. If the value is negative it means that there is a crank with incorrect values.

Public property CrankStraightLength0

Identifies the crank straight length at the start.

The default value is 0. A positive value means that there is a valid crank. If the value is 0 it means that there is no crank. If the value is negative it means that there is a crank with incorrect values.

Public property CrankStraightLength1

Identifies the crank straight length at the end.

The default value is 0. A positive value means that there is a valid crank. If the value is 0 it means that there is no crank. If the value is negative it means that there is a crank with incorrect values.

Public property HookAngle0 The angle (in degrees) of the hook at the start. Must be at least 0 and no more than 180. If the value is 0 it means that there is no hook. The default value is 0. When setting from 0 to another value, all crank lengths for start will be set to 0. When setting this value to 0 HookLength0 will be set to 0.
Public property HookAngle1 The angle (in degrees) of the hook at the end. Must be at least 0 and no more than 180. If the value is 0 it means that there is no hook. The default value is 0. When setting from 0 to another value all crank lengths for end will be set to 0. When setting this value to 0 HookLength1 will be set to 0.
Public property HookBendRadius The radius of the hook fillets in the Rebar shape. The default value is 0.0.
Public property HookLength0 The extension length of the hook at the start. The default value is 0.0.
Public property HookLength1 The extension length of the hook at the end. The default value is 0.0.
Public property HookOrient0 Obsolete.
Identifies the orientation of the termination (e.g. hook, crank) at the start. The default value is RebarTerminationOrientation::Left.
Public property HookOrient1 Obsolete.
Identifies the orientation of the termination (e.g. hook, crank) at the end. The default value is RebarTerminationOrientation::Left.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property TerminationOrientation0 Identifies he orientation of the termination (e.g. hook, crank) at the start. The default value is RebarTerminationOrientation::Left.
Public property TerminationOrientation1 Identifies the orientation of the termination (e.g. hook, crank) at the end. The default value is RebarTerminationOrientation::Left.
Public property TerminationRotationAngle0 Identifies the termination's rotation angle (in radians) at the start. The default value is 0.0
Public property TerminationRotationAngle1 Identifies he termination's rotation angle (in radians) at the end. The default value is 0.0
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RebarBendData
Top
See Also