Face |
A base class of output nodes that represent face edges and face silhouettes.

System Object
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB FaceDetailNode
Autodesk.Revit.DB FaceEdgeNode
Autodesk.Revit.DB FaceSilhouetteNode
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB FaceDetailNode
Autodesk.Revit.DB FaceEdgeNode
Autodesk.Revit.DB FaceSilhouetteNode
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The FaceDetailNode type exposes the following members.

Name | Description | |
---|---|---|
![]() | LineProperties | Access to the line (pen) properties of the curve being drawn. |

Name | Description | |
---|---|---|
![]() | GetInstanceTransform | Returns instance transform of the object being drawn. |
![]() | GetLinkTransform | Returns link transform of the object being drawn. |