Face |
A base class of output nodes that represent face edges and face silhouettes.

System Object
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB FaceDetailNode
Autodesk.Revit.DB FaceEdgeNode
Autodesk.Revit.DB FaceSilhouetteNode
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB FaceDetailNode
Autodesk.Revit.DB FaceEdgeNode
Autodesk.Revit.DB FaceSilhouetteNode
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The FaceDetailNode type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode ) |
![]() | LineProperties | Access to the line (pen) properties of the curve being drawn. |
![]() | NodeName | A readable name of the output node. (Inherited from RenderNode ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RenderNode ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetInstanceTransform | Returns instance transform of the object being drawn. |
![]() | GetLinkTransform | Returns link transform of the object being drawn. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |