FaceDetailNode Class


Face Detail Node Class

A base class of output nodes that represent face edges and face silhouettes.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FaceDetailNode : RenderNode

The FaceDetailNode type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode )
Public property LineProperties Access to the line (pen) properties of the curve being drawn.
Public property NodeName A readable name of the output node.
(Inherited from RenderNode )
Top
Methods
Name Description
Public method Dispose
(Inherited from RenderNode )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetInstanceTransform Returns instance transform of the object being drawn.
Public method GetLinkTransform Returns link transform of the object being drawn.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also