RebarReinforcementData Class


Rebar Reinforcement Data Class

class containing the id and the end of rebar on which the coupler stays
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure ReinforcementData
Autodesk.Revit.DB.Structure RebarReinforcementData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarReinforcementData : ReinforcementData

The RebarReinforcementData type exposes the following members.

Properties
Name Description
Public property End The end of the rebar. The end should be 0 or 1.
Public property RebarId The id of the Rebar
Top
Methods
Name Description
Public method Static member Create Creates a new instance of RebarReinforcementData, or if the operation fails.
Top
See Also