Rebar |
class containing the id and the end of rebar on which the coupler stays

System Object
Autodesk.Revit.DB.Structure ReinforcementData
Autodesk.Revit.DB.Structure RebarReinforcementData
Autodesk.Revit.DB.Structure ReinforcementData
Autodesk.Revit.DB.Structure RebarReinforcementData
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarReinforcementData type exposes the following members.

Name | Description | |
---|---|---|
![]() | End | The end of the rebar. The end should be 0 or 1. |
![]() | RebarId | The id of the Rebar |

Name | Description | |
---|---|---|
![]() ![]() | Create | Creates a new instance of RebarReinforcementData, or if the operation fails. |