Rebar |
class containing the id and the end of rebar on which the coupler stays

System Object
Autodesk.Revit.DB.Structure ReinforcementData
Autodesk.Revit.DB.Structure RebarReinforcementData
Autodesk.Revit.DB.Structure ReinforcementData
Autodesk.Revit.DB.Structure RebarReinforcementData
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarReinforcementData type exposes the following members.

Name | Description | |
---|---|---|
![]() | End | The end of the rebar. The end should be 0 or 1. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ReinforcementData ) |
![]() | RebarId | The id of the Rebar |

Name | Description | |
---|---|---|
![]() ![]() | Create | Creates a new instance of RebarReinforcementData, or if the operation fails. |
![]() | Dispose | (Inherited from ReinforcementData ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |