GetAllExternalResourceReferences Method (Document)


External Resource Utils Get All External Resource References(Document) Method

Gets the ids of all elements which refer to external resources.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ISet<ElementId> GetAllExternalResourceReferences(
	Document document
)

Parameters

document Document
The Revit Document containing the external resource references.

Return Value

ISet ElementId
The ids of all elements which refer to external resources.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This function will not return the ids of nested Revit links; it only returns top-level references.
See Also