External |
Gets the ids of all elements which refer to external resources.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- document Document
- The Revit Document containing the external resource references.
Return Value
ISet ElementIdThe ids of all elements which refer to external resources.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

This function will not return the ids of nested Revit links; it only returns top-level references.