Solid |
A class containing optional information to control the geometry generation of the Solid by the SolidUtils routines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The SolidGeometryOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | SolidGeometryOptions | Creates a new SolidOptions class with solid tag settings. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | SolidTag | Optional solid tag for the Solid. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the SolidGeometryOptions |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |