Solid |
A class containing optional information to control the geometry generation of the Solid by the SolidUtils routines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The SolidGeometryOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | SolidGeometryOptions | Creates a new SolidOptions class with solid tag settings. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | SolidTag | Optional solid tag for the Solid. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the SolidGeometryOptions |