Duplicate Method


View Duplicate Method

Duplicates this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementId Duplicate(
	ViewDuplicateOption duplicateOption
)

Parameters

duplicateOption ViewDuplicateOption
The option to use when duplicating the view.

Return Value

ElementId
The id of the newly created view.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException View cannot be duplicated
See Also