View Duplicate Method |
Duplicates this view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- duplicateOption ViewDuplicateOption
- The option to use when duplicating the view.
Return Value
ElementIdThe id of the newly created view.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
InvalidOperationException | View cannot be duplicated |

public View CreateDependentCopy(View view)
{
View dependentView = null;
ElementId newViewId = ElementId.InvalidElementId;
if (view.CanViewBeDuplicated(ViewDuplicateOption.AsDependent))
{
newViewId = view.Duplicate(ViewDuplicateOption.AsDependent);
dependentView = view.Document.GetElement(newViewId) as View;
if (null != dependentView)
{
if (dependentView.GetPrimaryViewId() == view.Id)
{
TaskDialog.Show("Dependent View", "Dependent view created successfully!");
}
}
}
return dependentView;
}