KeyBasedTreeEntry Class


Key Based Tree Entry Class

A key-based tree entry, containing the key, parent key, and children keys (if applicable).
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class KeyBasedTreeEntry : IDisposable

The KeyBasedTreeEntry type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Key The key of this entry.
Public property ParentKey The parent key of this entry.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the KeyBasedTreeEntry
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetChildrenKeys Gets a collection containing the keys of all children entry objects from this entry.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also