Key |
A key-based tree entry, containing the key, parent key, and children keys (if applicable).

System Object
Autodesk.Revit.DB KeyBasedTreeEntry
Autodesk.Revit.DB ClassificationEntry
Autodesk.Revit.DB KeynoteEntry
Autodesk.Revit.DB KeyBasedTreeEntry
Autodesk.Revit.DB ClassificationEntry
Autodesk.Revit.DB KeynoteEntry
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The KeyBasedTreeEntry type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Key | The key of this entry. |
![]() | ParentKey | The parent key of this entry. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the KeyBasedTreeEntry |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetChildrenKeys | Gets a collection containing the keys of all children entry objects from this entry. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |