StructuralMaterialType Enumeration


Structural Material Type Enumeration

Represents the structural material type. This enum value is returned by Autodesk::Revit::DB::FamilyInstance::StructuralMaterialType.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum StructuralMaterialType
Members
Member name Value Description
Aluminum 7 Structural material type is aluminum.
Concrete 2 Structural material type is concrete.
Generic 6 Structural material type is generic.
Other 4 Structural material type is other.
PrecastConcrete 5 Structural material type is precast concrete.
Steel 1 Structural material type is steel.
Undefined 0 Structural material type is undefined.
Wood 3 Structural material type is wood.
See Also