StructuralMaterialType Enumeration


Structural Material Type Enumeration

Represents the structural material type. This enum value is returned by Autodesk::Revit::DB::FamilyInstance::StructuralMaterialType.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum StructuralMaterialType
Members
Member name Value Description
Undefined 0 Structural material type is undefined.
Steel 1 Structural material type is steel.
Concrete 2 Structural material type is concrete.
Wood 3 Structural material type is wood.
Other 4 Structural material type is other.
PrecastConcrete 5 Structural material type is precast concrete.
Generic 6 Structural material type is generic.
Aluminum 7 Structural material type is aluminum.
See Also