Export |

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ExportLinetypeTable type exposes the following members.

Name | Description | |
---|---|---|
![]() | ExportLinetypeTable | Constructs a new ExportLinetypeTable with default values. |

Name | Description | |
---|---|---|
![]() | Count | Count of the items contained in the collection. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Item | A copy of the ExportLinetypeInfo for the linetype's ExportLinetypeKey . |

Name | Description | |
---|---|---|
![]() | Add | Inserts a (key, info) pair into Export line type table. |
![]() | Clear | Removes all contents stored in Export line type table. |
![]() | ContainsKey | Checks whether a pattern key exists in the table. |
![]() | Dispose | Releases all resources used by the ExportLinetypeTable |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. |
![]() | GetEnumerator | Returns an enumerator that iterates through a collection. |
![]() | GetExportLinetypeInfo | Gets a copy of the ExportLinetypeInfo corresponding to the given ExportLinetypeKey. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetKeys | Gets all the keys stored in the map. |
![]() | GetLinetypeTableIterator | Returns a ExportLinetypeTableIterator that iterates through the collection. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | GetValues | Returns all the values stored in the map. |
![]() | Remove | Removes the pair (key, info) corresponding to the given ExportLinetypeKey. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

This table is structured as a mapping from ExportLinetypeKey to ExportLinetypeInfo members. The ExportLinetypeKey contains the identification information for the pattern table: the Revit linetype name. The ExportLinetypeInfo contains the linetype name to use in the export format.
The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportLinetypeInfo returned will be a copy of the ExportLinetypeInfo from the table. In order to make changes to the ExportLinetypeInfo and use those settings during export, set the modified ExportLinetypeInfo back into the table using the same key.