ExportLinetypeTable Class


Export Linetype Table Class

A table supporting a mapping of linetypes in Revit to linetype names that will be set in the target export format.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExportLinetypeTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportLinetypeTable : IEnumerable<KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo>>, 
	IDisposable

The ExportLinetypeTable type exposes the following members.

Constructors
Name Description
Public method ExportLinetypeTable Constructs a new ExportLinetypeTable with default values.
Top
Properties
Name Description
Public property Count Count of the items contained in the collection.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Item A copy of the ExportLinetypeInfo for the linetype's ExportLinetypeKey .
Top
Methods
Name Description
Public method Add Inserts a (key, info) pair into Export line type table.
Public method Clear Removes all contents stored in Export line type table.
Public method ContainsKey Checks whether a pattern key exists in the table.
Public method Dispose Releases all resources used by the ExportLinetypeTable
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetEnumerator Returns an enumerator that iterates through a collection.
Public method GetExportLinetypeInfo Gets a copy of the ExportLinetypeInfo corresponding to the given ExportLinetypeKey.
Public method GetKeys Gets all the keys stored in the map.
Public method GetLinetypeTableIterator Returns a ExportLinetypeTableIterator that iterates through the collection.
Public method GetValues Returns all the values stored in the map.
Public method Remove Removes the pair (key, info) corresponding to the given ExportLinetypeKey.
Top
Remarks

This table is structured as a mapping from ExportLinetypeKey to ExportLinetypeInfo members. The ExportLinetypeKey contains the identification information for the pattern table: the Revit linetype name. The ExportLinetypeInfo contains the linetype name to use in the export format.

The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportLinetypeInfo returned will be a copy of the ExportLinetypeInfo from the table. In order to make changes to the ExportLinetypeInfo and use those settings during export, set the modified ExportLinetypeInfo back into the table using the same key.

See Also