Column |
Look up a column attachment by specifying the target id.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ColumnAttachment GetColumnAttachment(
FamilyInstance column,
ElementId targetId
)
Parameters
- column FamilyInstance
- A column.
- targetId ElementId
- Id of a target element.
Return Value
ColumnAttachmentThe column attachment attaching the column to the target, or if there is no such attachment.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

May return either a top or base attachment.