GetColumnAttachment Method (FamilyInstance, ElementId)


Column Attachment Get Column Attachment(Family Instance, Element Id) Method

Look up a column attachment by specifying the target id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ColumnAttachment GetColumnAttachment(
	FamilyInstance column,
	ElementId targetId
)

Parameters

column FamilyInstance
A column.
targetId ElementId
Id of a target element.

Return Value

ColumnAttachment
The column attachment attaching the column to the target, or if there is no such attachment.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
May return either a top or base attachment.
See Also