RepeaterCoordinates Class


Repeater Coordinates Class

Represents coordinates in the array of repeating references in 0, 1, or 2 dimensions.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RepeaterCoordinates

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RepeaterCoordinates : IDisposable

The RepeaterCoordinates type exposes the following members.

Constructors
Name Description
Public method RepeaterCoordinates Creates zero dimensional coordinates.
Public method RepeaterCoordinates(Int32) Creates one dimensional coordinates.
Public method RepeaterCoordinates(Int32, Int32) Creates two dimensional coordinates.
Top
Properties
Name Description
Public property DimensionCount The number of dimensions of the coordinates (0, 1 or 2 for zero, one or two dimensional arrays.)
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RepeaterCoordinates
Public method GetCoordinate Returns the coordinate in the given dimension.
Top
See Also