CreateRibbonPanel Method (String)


UIApplication Create Ribbon Panel(String) Method

Create a new RibbonPanel on the Add-Ins tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public virtual RibbonPanel CreateRibbonPanel(
	string panelName
)

Parameters

panelName String
The name of the panel to be created.

Return Value

RibbonPanel
Exceptions
Exception Condition
ArgumentNullException panelName is .
ArgumentException panelName is Empty.
InvalidOperationException If more than 100 panels were created.
Remarks
This method will create a custom panel appending to the Revit AddIns tab. This method is not supported in Macros.
See Also