CreateRibbonPanel Method (String)


UIApplication Create Ribbon Panel(String) Method

Create a new RibbonPanel on the Add-Ins tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual RibbonPanel CreateRibbonPanel(
	string panelName
)

Parameters

panelName String
The name of the panel to be created.

Return Value

RibbonPanel
Exceptions
Exception Condition
ArgumentNullException panelName is .
ArgumentException panelName is Empty.
InvalidOperationException If more than 100 panels were created.
Remarks
This method will create a custom panel appending to the Revit AddIns tab. This method is not supported in Macros.
Example
public Result OnStartup(UIControlledApplication application)
{
    // add new ribbon panel
    RibbonPanel ribbonPanel = application.CreateRibbonPanel("NewRibbonPanel");

    //Create a push button in the ribbon panel “NewRibbonPanel”
    //the add-in application “HelloWorld” will be triggered when button is pushed

    PushButton pushButton = ribbonPanel.AddItem(new PushButtonData("HelloWorld", 
        "HelloWorld", @"D:\HelloWorld.dll", "HelloWorld.CsHelloWorld")) as PushButton;

    // Set the large image shown on button
    Uri uriImage = new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png");
    BitmapImage largeImage = new BitmapImage(uriImage);
    pushButton.LargeImage = largeImage;


    return Result.Succeeded;
}
See Also