FindDefinition Method


Direct Shape Library Find Definition Method

Find a definition by id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<GeometryObject> FindDefinition(
	string id
)

Parameters

id String
Definition id. Expecected to be unique

Return Value

IList GeometryObject
List of geometry objects that together define a shape
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also