Rebar |
Class that encapsulates the result of the splice by rules operation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarSpliceByRulesResult type exposes the following members.

Name | Description | |
---|---|---|
![]() | Error | Identifies the error that occured during the splice by rules operation. In case of success the value of this property will be Success. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the RebarSpliceByRulesResult |
![]() | GetSpliceGeometries | Gets the RebarSpliceGeometry collection which is the result of the splice by rules operation. |

This class contains a collection of RebarSpliceGeometry which is the result of the splice and a RebarSpliceByRulesError member. After splice by rules operation check the Error member for RebarSpliceByRulesError.Success value and retrieve the RebarSpliceGeometry collection. If the splice by rules operation fails the Error member will contain a meaninful error.