RebarSpliceByRulesResult Class


Rebar Splice By Rules Result Class

Class that encapsulates the result of the splice by rules operation.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarSpliceByRulesResult

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarSpliceByRulesResult : IDisposable

The RebarSpliceByRulesResult type exposes the following members.

Properties
Name Description
Public property Error Identifies the error that occured during the splice by rules operation. In case of success the value of this property will be Success.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RebarSpliceByRulesResult
Public method GetSpliceGeometries Gets the RebarSpliceGeometry collection which is the result of the splice by rules operation.
Top
Remarks
This class contains a collection of RebarSpliceGeometry which is the result of the splice and a RebarSpliceByRulesError member. After splice by rules operation check the Error member for RebarSpliceByRulesError.Success value and retrieve the RebarSpliceGeometry collection. If the splice by rules operation fails the Error member will contain a meaninful error.
See Also