SetFromCurvesAndShape Method


Rebar Container Item Set From Curves And Shape Method


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetFromCurvesAndShape(
	RebarShape rebarShape,
	RebarBarType barType,
	RebarHookType startHook,
	RebarHookType endHook,
	XYZ norm,
	IList<Curve> curves,
	RebarHookOrientation startHookOrient,
	RebarHookOrientation endHookOrient
)

Parameters

rebarShape RebarShape
barType RebarBarType
startHook RebarHookType
endHook RebarHookType
norm XYZ
curves IList Curve
startHookOrient RebarHookOrientation
endHookOrient RebarHookOrientation
See Also