Rebar
|
Note: This API is now obsolete.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarContainerItem.SetFromCurvesAndShape(RebarShape rebarShape, RebarBarType barType, RebarHookType startHook, RebarHookType endHook, XYZ norm, IList<Curve> curves, RebarTerminationOrientation startHookOrient, RebarTerminationOrientation endHookOrient) instead.")]
public void SetFromCurvesAndShape(
RebarShape rebarShape,
RebarBarType barType,
RebarHookType startHook,
RebarHookType endHook,
XYZ norm,
IList<Curve> curves,
RebarHookOrientation startHookOrient,
RebarHookOrientation endHookOrient
)
Parameters
- rebarShape RebarShape
- barType RebarBarType
- startHook RebarHookType
- endHook RebarHookType
- norm XYZ
- curves IList Curve
- startHookOrient RebarHookOrientation
- endHookOrient RebarHookOrientation