MaterialFunctionAssignment Enumeration


Material Function Assignment Enumeration

Used in class CompoundStructure to specify the function of a layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum MaterialFunctionAssignment
Members
Member name Value Description
Finish1 4 Priority = 4
Finish2 5 Priority = 5
Insulation 3 Priority = 3
Membrane 100 A membrane layer must have thickness 0. It is not represented graphically.
None 0 Priority = 0 This is deprecated and should not be used.
StructuralDeck 200 Indicates layer is a structural deck.
Structure 1 Priority = 1 (highest priority)
Substrate 2 Priority = 2
Remarks
The function is used primarily to determine layer priority which affects how layers of distinct elements interact at a join. Typically, layers penetrate lower priority layers and merge with layers of the same priority.
See Also