MaterialFunctionAssignment Enumeration


Material Function Assignment Enumeration

Used in class CompoundStructure to specify the function of a layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public enum MaterialFunctionAssignment
Members
Member name Value Description
Finish1 4 Default priority = 4
Finish2 5 Default priority = 5 (The lowest effective priority)
Insulation 3 Default priority = 3
Membrane 100 A membrane layer must have thickness 0. It is not represented graphically.
None 0 Default priority = 0 This is deprecated and should not be used.
StructuralDeck 200 Default priority = 1. Indicates layer is a structural deck.
Structure 1 Default priority = 1 (The highest effective priority)
Substrate 2 Default priority = 2
Remarks
The function is used primarily to determine layer priority which affects how layers of distinct elements interact at a join. Typically, layers penetrate lower priority layers and merge with layers of the same priority.
See Also