Worksharing |
Gets worksharing information about an element to display in an in-canvas tooltip.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static WorksharingTooltipInfo GetWorksharingTooltipInfo(
Document document,
ElementId elementId
)
Parameters
- document Document
- The document containing the element
- elementId ElementId
- The id of the element in question
Return Value
WorksharingTooltipInfoWorksharing information about the specified element.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

If there is no element corresponding to the given id, then all the strings returned in WorksharingTooltipInfo are empty.
The return value may not be dependable in the middle of a transaction. See the remarks on WorksharingUtils for more details.