Filter |
Base for all classes that compare numeric values from Revit to a user-supplied filter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The FilterNumericRuleEvaluator type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the FilterNumericRuleEvaluator |
![]() | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. |
![]() | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. |
![]() | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. |

A class derived from FilterNumericRuleEvaluator must handle both integer and double-precision types. For double-precision comparisons, an epsilon value is given. The evaluator class should use this value in a manner appropriate to the comparison being implemented.

Reference