Filter
|
Base for all classes that compare numeric values from Revit to a user-supplied filter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The FilterNumericRuleEvaluator type exposes the following members.

Name | Description | |
---|---|---|
![]() |
IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() |
Dispose | Releases all resources used by the FilterNumericRuleEvaluator |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. |
![]() |
Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |

A class derived from FilterNumericRuleEvaluator must handle both integer and double-precision types.
For double-precision comparisons, an epsilon value is given. The evaluator class should use this
value in a manner appropriate to the comparison being implemented.

Reference

System
Object
Autodesk.Revit.DB FilterNumericRuleEvaluator
Autodesk.Revit.DB FilterNumericEquals
Autodesk.Revit.DB FilterNumericGreater
Autodesk.Revit.DB FilterNumericGreaterOrEqual
Autodesk.Revit.DB FilterNumericLess
Autodesk.Revit.DB FilterNumericLessOrEqual
Autodesk.Revit.DB FilterNumericRuleEvaluator
Autodesk.Revit.DB FilterNumericEquals
Autodesk.Revit.DB FilterNumericGreater
Autodesk.Revit.DB FilterNumericGreaterOrEqual
Autodesk.Revit.DB FilterNumericLess
Autodesk.Revit.DB FilterNumericLessOrEqual