Polyloop Class


Polyloop Class

A Polyloop represent a planar polygon with ordered points.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis Polyloop

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Polyloop : IDisposable

The Polyloop type exposes the following members.

Properties
Name Description
Public property Centroid The polygon centroid.
Public property Direction The direction for the outward normal for this polygon.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method ComputeArea Gets the area for this polygon.
Public method Dispose Releases all resources used by the Polyloop
Public method GetPoints Gets the array of points in the polygon.
Top
Remarks
This class is a loop with straight edges bounding a planar region in space. The loop is represented by an ordered coplanar collection of points forming the vertices of the loop. The loop is composed of straight line segments joining a point in the collection to the succeeding point in the collection. The closing segment is from the last to the first point in the collection. The direction of the loop is in the direction of the line segments. All the points in the polygon defining the poly loop shall be coplanar.
See Also