Polyloop Class |
A Polyloop represent a planar polygon with ordered points.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The Polyloop type exposes the following members.

Name | Description | |
---|---|---|
![]() | Centroid | The polygon centroid. |
![]() | Direction | The direction for the outward normal for this polygon. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | ComputeArea | Gets the area for this polygon. |
![]() | Dispose | Releases all resources used by the Polyloop |
![]() | GetPoints | Gets the array of points in the polygon. |

This class is a loop with straight edges bounding a planar region in space. The loop is represented by an ordered coplanar collection of points forming the vertices of the loop. The loop is composed of straight line segments joining a point in the collection to the succeeding point in the collection. The closing segment is from the last to the first point in the collection. The direction of the loop is in the direction of the line segments. All the points in the polygon defining the poly loop shall be coplanar.