IntersectingElementData Class


Intersecting Element Data Class

Stores information of an element that intersects with another element
Inheritance Hierarchy
System Object
Autodesk.Revit.DB IntersectingElementData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IntersectingElementData : IDisposable

The IntersectingElementData type exposes the following members.

Properties
Name Description
Public property IntersectedElementId Id of the intersected element.
Public property IntersectingElementId Id of the intersecting element.
Public property IntersectionType The intersection type.
Public property IntersectionVolume The intersection volume.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the IntersectingElementData
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also