Intersecting |
Stores information of an element that intersects with another element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The IntersectingElementData type exposes the following members.

Name | Description | |
---|---|---|
![]() | IntersectedElementId | Id of the intersected element. |
![]() | IntersectingElementId | Id of the intersecting element. |
![]() | IntersectionType | The intersection type. |
![]() | IntersectionVolume | The intersection volume. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the IntersectingElementData |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |