MEPCalculationServerInfo Class


MEPCalculation Server Info Class

a struct to hold the information about a MEP calucation servers
Inheritance Hierarchy
System Object
Autodesk.Revit.DB MEPCalculationServerInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MEPCalculationServerInfo : IDisposable

The MEPCalculationServerInfo type exposes the following members.

Constructors
Name Description
Public method MEPCalculationServerInfo Constructs a new MEPCalculationServerInfo with default settings.
Public method MEPCalculationServerInfo(IExternalServer) Create a new MEPCalculationServerInfo by an external server.
Public method MEPCalculationServerInfo(MEPCalculationServerInfo) Constructs a new copy of the input MEPCalculationServerInfo object.
Top
Properties
Name Description
Public property Description The Description of the server.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Static member PipeUseDefinitionOnTypeGUID The guid value ("3BF616F9-6B98-4A21-80FF-DA1120C8F6D6") of Use Definition On Type. It is not a server id, but a guid to tell if the loss method is "Use Definition On Type" or not. If the loss method is "Use Definition On Type", we use the loss method of the family type to calculate.
Public property ServerId The Id of the server.
Public property ServerName The Name of the server.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the MEPCalculationServerInfo
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method Static member GetMEPCalculationServerInfo Gets a MEPCalculationServerInfo by family instance.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also