MEPCalculation |
a struct to hold the information about a MEP calucation servers

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The MEPCalculationServerInfo type exposes the following members.

Name | Description | |
---|---|---|
![]() | MEPCalculationServerInfo | Constructs a new MEPCalculationServerInfo with default settings. |
![]() | MEPCalculationServerInfo(IExternalServer) | Create a new MEPCalculationServerInfo by an external server. |
![]() | MEPCalculationServerInfo(MEPCalculationServerInfo) | Constructs a new copy of the input MEPCalculationServerInfo object. |

Name | Description | |
---|---|---|
![]() | Description | The Description of the server. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() ![]() | PipeUseDefinitionOnTypeGUID | The guid value ("3BF616F9-6B98-4A21-80FF-DA1120C8F6D6") of Use Definition On Type. It is not a server id, but a guid to tell if the loss method is "Use Definition On Type" or not. If the loss method is "Use Definition On Type", we use the loss method of the family type to calculate. |
![]() | ServerId | The Id of the server. |
![]() | ServerName | The Name of the server. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the MEPCalculationServerInfo |
![]() ![]() | GetMEPCalculationServerInfo | Gets a MEPCalculationServerInfo by family instance. |