GetModifiedElementIds Method (ElementFilter)


Document Changed Event Args Get Modified Element Ids(Element Filter) Method

Returns set of elements that were modified according to the given element filter.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ICollection<ElementId> GetModifiedElementIds(
	ElementFilter filter
)

Parameters

filter ElementFilter
The element filter to be applied.

Return Value

ICollection ElementId
The set of ElementId for modified elements that pass the filter. Returns empty set if no elements are found which pass the filter.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also