RebarShapeConstraintAngleFromFixedDir Constructor


Rebar Shape Constraint Angle From Fixed Dir Constructor

Create an angular constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RebarShapeConstraintAngleFromFixedDir(
	ElementId paramId,
	int sign,
	UV direction
)

Parameters

paramId ElementId
A Rebar Shape parameter of type UT_Angle.
sign Int32
The sign of the angle relative to the direction.
direction UV
A fixed direction in UV-space.
Exceptions
Exception Condition
ArgumentException sign is not 1 or -1. -or- paramId is not a valid Element identifier.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException direction has zero length.
See Also