Rebar |
Create an angular constraint.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public RebarShapeConstraintAngleFromFixedDir(
ElementId paramId,
int sign,
UV direction
)
Parameters

Exception | Condition |
---|---|
ArgumentException | sign is not 1 or -1. -or- paramId is not a valid Element identifier. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | direction has zero length. |