FailureDefinitionAccessor Class


Failure Definition Accessor Class

A class that provides access to the details of a FailureDefinition after the definition has been defined.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FailureDefinitionAccessor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FailureDefinitionAccessor : IDisposable

The FailureDefinitionAccessor type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FailureDefinitionAccessor
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetApplicableResolutionTypes Retrieves a list of resolution types applicable to the failure.
Public method GetDefaultResolutionType Retrieves the default resolution type for the failure.
Public method GetDescriptionText Retrieves the description text of the failure.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetId Retrieves the unique identifier of the FailureDefinition.
Public method GetResolutionCaption Retrieves the caption for a specific resolution type.
Public method GetSeverity Retrieves severity of the failure.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method HasResolutions Checks if the FailureDefinition has at least one resolution.
Public method IsResolutionApplicable Checks if the given resolution type is applicable to the failure.
Public method SetDefaultResolutionType Sets the default resolution type for the failure.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also