Failure |
A class that provides access to the details of a FailureDefinition after the definition has been defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The FailureDefinitionAccessor type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the FailureDefinitionAccessor |
![]() | GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure. |
![]() | GetDefaultResolutionType | Retrieves the default resolution type for the failure. |
![]() | GetDescriptionText | Retrieves the description text of the failure. |
![]() | GetId | Retrieves the unique identifier of the FailureDefinition. |
![]() | GetResolutionCaption | Retrieves the caption for a specific resolution type. |
![]() | GetSeverity | Retrieves severity of the failure. |
![]() | HasResolutions | Checks if the FailureDefinition has at least one resolution. |
![]() | IsResolutionApplicable | Checks if the given resolution type is applicable to the failure. |
![]() | SetDefaultResolutionType | Sets the default resolution type for the failure. |