City Class


City Class

An object that contains geographical location information for a known city.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB City

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class City : APIObject

The City type exposes the following members.

Properties
Name Description
Public property Latitude Latitude of the city
Public property Longitude Longitude of the city
Public property Name The name of the city
Public property TimeZone Time-zone in which the city resides
Public property WeatherStation An identifier for the nearest weather station
Top
Methods
Name Description
Top
Remarks
This object contains longitude, latitude, time zone information for a city already known by Revit. Currently Revit does not the ability to add cities to the existing list. The list of known cities can be retrieved using the Cities property on the application object.
See Also