Create Method (Document, Arc)


Grid Create(Document, Arc) Method

Creates a new radial grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static Grid Create(
	Document document,
	Arc arc
)

Parameters

document Document
The document in which the new instance is created.
arc Arc
An arc object that represents the location of the new grid line.

Return Value

Grid
The newly created grid line.
Exceptions
Exception Condition
ArgumentException document is not a project document. -or- The input arc is not on horizontal plane.
ArgumentNullException A non-optional argument was null
Remarks
The arc should be on a horizontal plane.
See Also